最近升级了wordpress后突然提示我正在运行不安全的php版本,但我这个php7.1用了这么久也没出现过问题。。。
但是这行提示看着烦人,就打算还是升级一下。
不知道为什么网上找的centos升级到php7.4的方法要么很麻烦要重新编译,要么就是源里找不到这个版本,但我源的确安装了。
找了很久终于找到一个能用的源。
sudo yum -y install https://dl.fedoraproject.org/pub/epel/epel-release-latest-8.noarch.rpm
启用这个源
yum-config-manager --enable remi-php74
查看已安装的php组件
yum list installed | grep php
删除旧版本的php
yum remove php(可能带有版本号,如php71w)
yum remove php-*
安装新版本
yum install php php-cli php-fpm php-mysqlnd php-zip php-devel php-gd php-mcrypt php-mbstring php-curl php-xml php-pear php-bcmath php-json php-redis
查看安装完后的版本
php -v
可以看到版本已经变为php 7.4.x了,这样就算是可以了。
ps:更新貌似会导致phpMyAdmin无法使用,好像要重新安装


吾辈名为秋月琥珀,今后也请多多关照了